Search found 48 matches

Go to advanced search

by PGoncalves
Thu Jul 07, 2016 6:47 am
Forum: Installation
Topic: RasPi3 problem
Replies: 4
Views: 1699

Re: RasPi3 problem

Hi Jimmy,

I might miss a couple, but python will complain if I do - keep an eye out for the console ;)

- six
- python-dateutil
- numpy
- pyserial
- pybluez
- h5py
- mysql-connector-python
- tornado
- pycrypto
- scipy
- matplotlib
- biplist
- certifi
- requests

Best of Lucks :)
by PGoncalves
Wed Jul 06, 2016 9:06 am
Forum: Installation
Topic: RasPi3 problem
Replies: 4
Views: 1699

Re: RasPi3 problem

Hi Jimmy, That error is because the python encapsulated in OpenSignals is for Ubuntu amd64 and your architecture is different. My advice to you is that you use your own python (should be already installed on your OS), install the dependencies and run OpenSignals with it. To change the python that Op...
by PGoncalves
Fri Jun 24, 2016 3:09 pm
Forum: Installation
Topic: OpenSignals installation on Raspberry pi 3
Replies: 1
Views: 770

Re: OpenSignals installation on Raspberry pi 3

Hi,

Can you describe what you are doing and the exception that you are getting?
If the extracted file is corrupted, you can try to download it again.
No, it does not require Chrome to download the file, only to run the software after installation.

Best Regards,
by PGoncalves
Fri Jun 17, 2016 4:38 pm
Forum: Installation
Topic: OpenSignals on Raspbian on a Rasperry Pi 3
Replies: 13
Views: 3113

Re: OpenSignals on Raspbian on a Rasperry Pi 3

Hi again, Please edit /opt/OpenSignals (r)evolution/code/main.py and delete, around line 106, the line: tornado.ioloop.IOLoop.instance().stop() Then, edit /opt/OpenSignals (r)evolution/static/_OpenSignals_websocket.js and delete, around line 12, the line: window.close() This is to make sure that if ...
by PGoncalves
Thu Jun 16, 2016 7:02 am
Forum: Installation
Topic: OpenSignals on Raspbian on a Rasperry Pi 3
Replies: 13
Views: 3113

Re: OpenSignals on Raspbian on a Rasperry Pi 3

Now click on console tab and let me know if there's something there, but it doesn't seem like it. Try editing the file /opt/OpenSignals (r)evolution/code/main.py and replace, around line 127, the command google-chrome for chromium-browser Also, check under your /home/{you}/ if there's a /Documents/O...
by PGoncalves
Wed Jun 15, 2016 2:58 pm
Forum: Installation
Topic: OpenSignals on Raspbian on a Rasperry Pi 3
Replies: 13
Views: 3113

Re: OpenSignals on Raspbian on a Rasperry Pi 3

I have installed the same Chromium version you do and it works fine.
The console shows no errors?
by PGoncalves
Wed Jun 15, 2016 1:44 pm
Forum: Installation
Topic: OpenSignals on Raspbian on a Rasperry Pi 3
Replies: 13
Views: 3113

Re: OpenSignals on Raspbian on a Rasperry Pi 3

Hi again, So it does open the browser with the blinking OpenSignals cloud, correct? Do you have your Chromium Browser up to date? If you don't, please update and try again. If you do, can you send me the version you have? Can you open the browser console (F12 or Settings > More Tools > Developer Too...
by PGoncalves
Wed Jun 15, 2016 11:44 am
Forum: Installation
Topic: OpenSignals on Raspbian on a Rasperry Pi 3
Replies: 13
Views: 3113

Re: OpenSignals on Raspbian on a Rasperry Pi 3

Hello again :) Good job on changing to the system Python. Make sure you don't miss any dependencies :) When outside of Windows, OpenSignals uses the BITalino Python API that connect to the device via Serial Port. This means that if OpenSignals doesn't start, the problem is somewhere else. What is th...
by PGoncalves
Thu May 19, 2016 6:34 am
Forum: Programming APIs
Topic: How to import BITalino JAVA api?
Replies: 12
Views: 2781

Re: How to import BITalino JAVA api?

Hi,

Nice to hear that you found a workaround to the problem with the BITalino Python API.
Nevertheless, if it is a bug, it's in our best interest to try and find the problem :D.
Could you post the error that you are receiving when using the stop() function in the API?

Best Regards,
by PGoncalves
Fri May 13, 2016 3:07 pm
Forum: Installation
Topic: OpenSignals on Raspbian on a Rasperry Pi 3
Replies: 13
Views: 3113

Re: OpenSignals on Raspbian on a Rasperry Pi 3

Hi and welcome to the BITalino community :) In order to install OpenSignals (r)evolution on Raspbian, you need to follow these steps: 1. Install Google Chrome: https://www.google.com/chrome/ 2. Download the OpenSignals (r)evolution tarball: http://downloads.plux.info/OpenSignals/OpenSignals_(r)evolu...

Go to advanced search

cron