Page 1 of 1

RasPi3 problem

Posted: Mon Jul 04, 2016 5:07 am
by jimmyneutron
i already installed the opensignals software but it wont open. when i run it in the terminal it says:
/usr/bin/opensignals: line 11: ./python_linux_amd64/bin/pyhton: cannot execute binary file: Exec format error.

Re: RasPi3 problem

Posted: Mon Jul 04, 2016 6:13 am
by jimmyneutron
BTW im using Raspberry pi 3 on jessie.

Re: RasPi3 problem

Posted: Wed Jul 06, 2016 9:06 am
by PGoncalves
Hi Jimmy,

That error is because the python encapsulated in OpenSignals is for Ubuntu amd64 and your architecture is different.
My advice to you is that you use your own python (should be already installed on your OS), install the dependencies and run OpenSignals with it.

To change the python that OpenSignals use, edit the file:

{OpenSignals_install_dir}/start_linux_amd64

and replace the line

./python_linux_amd64/bin/python

with the new python executable directory.

After changing this path, run this script from the terminal and install the modules that are missing:

"No module named X"

Let me know if it works,
Best Regards,

Re: RasPi3 problem

Posted: Wed Jul 06, 2016 1:25 pm
by jimmyneutron
which dependencies are you pertaining to? Thanks. :)

Re: RasPi3 problem

Posted: Thu Jul 07, 2016 6:47 am
by PGoncalves
Hi Jimmy,

I might miss a couple, but python will complain if I do - keep an eye out for the console ;)

- six
- python-dateutil
- numpy
- pyserial
- pybluez
- h5py
- mysql-connector-python
- tornado
- pycrypto
- scipy
- matplotlib
- biplist
- certifi
- requests

Best of Lucks :)